CoSign: Collaborative Single Sign-On  

cosign-discuss at
general discussion of cosign development and deployment

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cosign install on rh linux 9

ooh, this may be the problem John Maddock ran into, I have a fix for it in 1.5.1 or 1.6. For now give this snap shot a whirl and see if you are still getting this behavior when you run the regular configure command ( no mysql ). Also, you may need to preface configure with "CPPFLAGS=-I/usr/kerberos/include ./configure" due to the non-standard location of kerberos on rh 9. This will all be fixed and smooth in the next release :)


On Feb 20, 2004, at 3:11 PM, Darren Jacobs wrote:

Hi Johanna,

I've tried using :

'configure --enable-krb=/usr/kerberos' and 'configure --enable-krb=/usr/kerberos --enable-mysql=no'

and I've gotten the same error message about crypt (In function `main': /usr/local/src/cosign-1.5.0/cgi/cgi.c:374: undefined reference to `crypt') as I did with :

'configure --enable-krb=/usr/kerberos --enable-ssl=/usr/local/src/openssl-0.9.7a --enable-mysql=/usr/bin/mysql --with-cosigndb=yyyy --with-frienddblogin=zzzz --with-frienddbpasswd=xxxxxx --with-apache-apxs=/usr/local/apache/bin/apxs'

Anything else I can try?



johanna bromberg craig wrote:

unless you want to use the friend functionality ( which i guess you don't cos you are giving it bogus options ;) there is no need to enable mysql. That said, the code it's dying on would be ifdef'd out. that also said, i wonder why the code is dying. :)

And with that said I'll take a look at this on our RedHat 9 test box here. :)


Copyright © 2002 - 2004 Regents of the University of Michigan :  Page last updated 15-December-2010