CoSign: Collaborative Single Sign-On  

cosign-discuss at
general discussion of cosign development and deployment

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: IISCosign - Looping problem on Windows 2003

 Alright - that worked!

 I really appreciate the help.

 The openssl command returned a good answer, meaning that the certificate
will expire in the future.

 The re/hashing is where the problem was.  I completely overlooked this step
and was heading down the wrong direction with trying to install the um cert
as a trusted ca using windows ca authority.

 After re/hashing the um.pem file and changing the config file - all worked!
(note on windows 2003 - the cosign dll needs to be added as a "Web Service
Extension" and be "allowed" from IIS Manager)

Thanks Again,


On 4/4/05 4:03 PM, "Jarod Malestein" <jarod@xxxxxxxxx> wrote:

> This is usually caused by an expired cert or bad CA file.
> Open a command prompt, CD to your IICosign folder, and run the following
> command:
> openssl x509 -in ./ssl/[] -dates
> Replacing the ./ssl/... with the relative path to your server's cert.  The
> notAfter= date is the important part since that will tell us how long your
> cert is good for.
> Also, what version of the filter DLL are you running?  If it's 1.1.1,
> you'll need to do some hashing.  See this:
> <>
> --Jarod Malestein
> --On Wednesday, March 30, 2005 11:32 AM -0500 Elias Asfaw-Kirby
> <eliasak@xxxxxxxxx> wrote:
>> Has anybody on the Windows platform run into the looping problem
>> with IISCosign?
>> Thanks,
>> --
>> Elias Asfaw-Kirby | 734-615-6490
>> Web Developer     | eliasak@xxxxxxxxx

Elias Asfaw-Kirby | 734-615-6490
Web Developer     | eliasak@um

Copyright © 2002 - 2004 Regents of the University of Michigan :  Page last updated 15-December-2010