CoSign: Collaborative Single Sign-On  

cosign-discuss at
general discussion of cosign development and deployment

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cosign login on Mac 10.3.6 Server


I was using --with instead of --enable.

Still I'm having a problem with telling it where Apache is located. I'm trying to use the Apache built into OS X Server. Manuals I have say that the Apache binaries are located in /usr/sbin. Below is the output when I try this. I've tried other system directories with the same result.



issstasks:/usr/local/bin/cosign-1.7.0 root# ./configure --enable-apache1=/usr/sbin
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for a BSD-compatible install... /usr/bin/install -c
checking for flex... flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for bison... bison -y
checking build system type... powerpc-apple-darwin7.6.0
checking host system type... powerpc-apple-darwin7.6.0
checking for inet_ntoa in -lnsl... no
checking for socket in -lsocket... no
checking for apache 1.3... configure: error: cannot find apache 1.3
issstasks:/usr/local/bin/cosign-1.7.0 root#

Doug Heady
Information Systems Shared Support
University of Michigan
503 Thompson St., Fleming Bldg., Room 108
Ann Arbor, MI 48109-1340
Phone: 734-615-3336 Fax: 734-615-3590
Computing Systems Support for: Presidents Office., Provost Office, VP for Gov't. Relations, VP for Communications, Regents, VP & Sec. of the Univ., OAMI, General Counsel, VP of Research, Budget & Planning, & VP of Student Affairs
ISSS webpage:

On Nov 15, 2004, at 10:08 AM, Phil Pishioneri wrote:

On 11/15/2004 09:23 AM, Doug Heady wrote:

This is my first attempt at building on OS X Server, so some of my problems may be experience related.

Below is the output of running ./configure. I did try to add options to include the apache binary path (/usr/sbin), kerberos IV-V, and GSS. These didn't help or they weren't in the right combination.


You didn't tell configure which apache you want to build against:

apache 1.3 not enabled
apache 2 not enabled

You need one of

    --enable-apache1=path_to_apxs_1.3   enables Apache 1.3 filter
    --enable-apache2=path_to_apxs_2     enables Apache 2 filter

Or show us the output from when you did add options (and how you specified them).


Copyright © 2002 - 2004 Regents of the University of Michigan :  Page last updated 15-December-2010